BVN Service Availability
Incident Report for QoreID
Postmortem

This incident has been resolved. thank you

Posted Aug 07, 2023 - 15:37 CET

Resolved
We are currently investigating this issue
Posted Dec 08, 55568 - 11:52 CET
This incident affected: DIGITAL IDENTITY VERIFICATION (BVN VERIFICATION API).