BVN Service Availability
Incident Report for QoreID
Postmortem

This incident has been resolved. thank you

Posted Aug 08, 2023 - 22:16 CET

Resolved
We are currently investigating this issue
Posted Jun 07, 55572 - 13:59 CET
This incident affected: DIGITAL IDENTITY VERIFICATION (BVN VERIFICATION API).