BVN Service Availability
Incident Report for QoreID
Postmortem

This incident has been resolved. thank you

Posted Aug 09, 2023 - 15:12 CET

Resolved
We are currently investigating this issue
Posted May 14, 55574 - 03:15 CET
This incident affected: DIGITAL IDENTITY VERIFICATION (BVN VERIFICATION API).