BVN Service Availability
Incident Report for QoreID
Postmortem

We are currently investigating this issue

Posted Jul 31, 2023 - 01:41 CET

Resolved
We are currently investigating this issue
Posted Mar 07, 55548 - 23:19 CET
This incident affected: DIGITAL IDENTITY VERIFICATION (BVN VERIFICATION API).