BVN Service Availability

Incident Report for QoreID

Postmortem

This incident has been resolved. thank you

Posted Jul 31, 2023 - 01:46 CET

Resolved

We are currently investigating this issue
Posted Mar 11, 55548 - 10:32 CET
This incident affected: DIGITAL IDENTITY VERIFICATION (BVN VERIFICATION API).