BVN Service Availability
Incident Report for QoreID
Postmortem

We are currently investigating this issue

Posted Jul 31, 2023 - 10:35 CET

Resolved
This incident has been resolved.
Posted Mar 13, 55549 - 19:17 CET
This incident affected: DIGITAL IDENTITY VERIFICATION (BVN VERIFICATION API).