NUBAN BVN Service Availability
Incident Report for QoreID
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 15:06 CET
Investigating
We are currently investigating this issue
Posted Jul 25, 2024 - 15:01 CET
This incident affected: ACCOUNT NUMBER VERIFICATION (NUBAN VERIFICATION API (BVN)).