BVN Service Availability
Incident Report for QoreID
Postmortem

We are currently investigating this issue

Posted Aug 09, 2023 - 15:07 CET

Resolved
This incident has been resolved.
Posted May 10, 55574 - 16:40 CET
This incident affected: DIGITAL IDENTITY VERIFICATION (BVN VERIFICATION API).