BVN Service Availability

Incident Report for QoreID

Postmortem

We are currently investigating this issue

Posted Aug 09, 2023 - 01:21 CET

Resolved

This incident has been resolved.
Posted Oct 14, 55572 - 01:50 CET
This incident affected: DIGITAL IDENTITY VERIFICATION (BVN VERIFICATION API).