BVN Service Availability
Incident Report for QoreID
Postmortem

We are currently investigating this issue

Posted Jul 31, 2023 - 01:12 CET

Resolved
This incident has been resolved.
Posted Feb 16, 55548 - 19:10 CET
This incident affected: DIGITAL IDENTITY VERIFICATION (BVN VERIFICATION API).